BuddyClub N+ replacement top mounts?

carlos7777777

Advanced Member
Messages
345
Hi all,

I've just had the car in the garage for an MOT and the top mounts and bearings have come back as an advisory. I've asked the garage to fix the issue so they ordered the OEM top mounts - which took nearly 3 weeks due to the recent cyber attack on Honda!

Problem is, no that the parts have turned up, the garage has advised that the top mounts already fitted to the car are different to OEM and that the OEM may not fit? Has anyone else had this issue before and if so what top mounts were fitted?

The garage is reluctant to try and fit the OEM top mounts incase they dont fit as they would then not be refundable as they would have been opened.

I have tried calling TGM but it goes to answer machine. SPD (buddyclub) also aren't too sure and have advised just to replace some 'black bushes' although the bearing makes the groaning noise?

I'm not really sure what my options are, would I have to replace the whole coilover suspension or should the OEM top mounts fit the Buddyclub N+ coilovers?

Any help would be greatly appreciated!

Kind regards,
Carl.
 

carl hammond

Advanced Member
Messages
3,351
Got a pic of your topmounts mate? Tom (TGM) was at brands all day testing so that’ll be why there was no answer.

mid yours are coilovers with adjustability (camber) then I’m 90% certain they won’t won’t with oem as oem are also quite big compared to others and have the bearing separate under them.

The only coilovers I know of that work with oem are Bilstein

Grab a pic and I’ll see if my mate can get you some

Carl
 

carlos7777777

Advanced Member
Messages
345
Hi mate,

Thanks for your input. Unfortunately the car is at the garage so can't get some pictures of them.

I'll ring the garage and see if they can get a picture sorted for me. In the meantime i'll also try TGM again as I believe they may have originally installed these and completed the FRSU.

Cheers,
Carl.
 

carlos7777777

Advanced Member
Messages
345
Hi Carl,

Thanks for that!

I have spoken to the garage who have also been in contact with SPD who has also forwarded them pictures; we have a bush set on order for the front struts and the OEM mounts are being returned.

Hopefully these bushes sort the issue and apparently it will. If the bushes don't do it then I may consider that set or alternatively buy a different brand new set in the near future as this is only an advisory at the moment.
 
Top