ABS Code 15

2Cent

Member
Messages
5
Hi all, I'm new on this forum.

I got round to diagnosing my ABS today and got rid of all but one code, code 15.

According to the manual this is for a short with the Right Rear ABS sensor. I followed the DTC troubleshooting instructions, made checks for voltage/resistance and it all checked out.

The last check (7) is for resistance between the positive and negative terminals of the sensor on the 25 pin ABS module connector. This checked out, I got about 1500ohm confirming there is no short between the sensor and the connector and the ABS module. Having found a resistance I should now look for loose terminals on the connector. I've messed with the pins both on the 25p connector and ABS module but can't find anything loose so I'm suspicious of the abs modulator itself.

Has anyone experienced this? Hopefully I can find a fault without needing a new abs module
 

Vteccin_teg

Advanced Member
Messages
163
Have you checked the condition of the pins on the module itself without the plug in, have you also checked the condition of pins inside the plug?
Resistance could be a bad earth on the module itself or indeed a faulty module, could try a different earth into the module and see if that helps? I don't know if its a constant earth or a switched earth though.

Normally when im wiring circuits up, when I get resistance its 9/10 earth related problems.
Could be a broken solder joint on the circuit board, a broken/corroded wire. could be wrong but just my 2 pence mate.

Can you swap abs sensors around on rear 2 wheels or are they side specific?
See if it throws a different code up?

Sent from my SM-G986B using Tapatalk
 

2Cent

Member
Messages
5
Thanks for the response.

The pins on both the convector and module look clean and straight. I looked them and they don't look loose either

I believe the resistance is supposed to be there across the sensor.

Maybe I can find the tools to pull the wires out of the connector and swap them.

Has anyone opened an abs module? Is this worth it?
 

Vteccin_teg

Advanced Member
Messages
163
Id say the quickest, and relatively cheapest in comparison to your other options to fix the issue would be to try buying and fitting a new sensor and see if that works. If it does then great.
If it doesn't you know its something between the sensor and module thats gone faulty.

Sent from my SM-G986B using Tapatalk
 

2Cent

Member
Messages
5
Today I tried to swap the left and right sensors but I still got code 15. I then unplugged both and still only got code 15 so I also unplugged the front right and still got only code 15!

My abs module must be broken...
 

Vteccin_teg

Advanced Member
Messages
163
2Cent said:
Today I tried to swap the left and right sensors but I still got code 15. I then unplugged both and still only got code 15 so I also unplugged the front right and still got only code 15!

My abs module must be broken...
Did you reset your dashbosrd lights via diagnostic tools after every swap?

Sent from my SM-G986B using Tapatalk
 

2Cent

Member
Messages
5
Vteccin_teg said:
Did you reset your dashbosrd lights via diagnostic tools after every swap?

Sent from my SM-G986B using Tapatalk
Yes, I shorted the obd2 connector and followed the reset procedure.
[sharedmedia=core:attachments:6549]
 

Vteccin_teg

Advanced Member
Messages
163
https://www.amazon.co.uk/dp/B00YVHGTBM/ref=cm_sw_r_other_apa_i_0.r6EbYBWZBCN

This is what I bought and use to reset codes.

Your method may not work on all fault codes. It might do though im unsure.

With that link I sent you aswell, you can buy 1 week subscription or a year. I just buy a week.

It also let's you change and unlock certain features on cars (mainly VAG cars).
I use it to reset dash lights at work if I've left something unplugged and turn engine on and it brings a light on. Might be worth a try?



Sent from my SM-G986B using Tapatalk
 

2Cent

Member
Messages
5
Vteccin_teg said:
https://www.amazon.co.uk/dp/B00YVHGTBM/ref=cm_sw_r_other_apa_i_0.r6EbYBWZBCN

This is what I bought and use to reset codes.

Your method may not work on all fault codes. It might do though im unsure.

With that link I sent you aswell, you can buy 1 week subscription or a year. I just buy a week.

It also let's you change and unlock certain features on cars (mainly VAG cars).
I use it to reset dash lights at work if I've left something unplugged and turn engine on and it brings a light on. Might be worth a try?



Sent from my SM-G986B using Tapatalk
It should work but even if it didn't, why do I only see code 15 when I've unplugged the other wheel sensors...
 

Vteccin_teg

Advanced Member
Messages
163
Not a clue mate. They could possibly throw the same code up, id doubt it though. If an abs module isn't too much id prob try replacing it.
If you've moved all the sensors around and code hasn't gone or changed. It could be a short in the module itself.


Sent from my SM-G986B using Tapatalk
 
Top